Issue with add-ons and booking multiple appointments
Incident Report for Acuity Scheduling
Resolved
This incident has been resolved.
Posted Aug 26, 2024 - 14:07 EDT
Investigating
We are aware of an issue affecting some Client Scheduling Pages. Engineering is currently working to resolve it.
Posted Aug 26, 2024 - 14:01 EDT
This incident affected: Acuity Scheduling.