Some users outside of the US are having trouble loading acuityscheduling.com

Incident Report for Acuity Scheduling

Resolved

This incident has been resolved.
Posted Aug 24, 2023 - 10:19 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 24, 2023 - 10:00 EDT

Investigating

We are currently investigating this issue.
Posted Aug 24, 2023 - 09:48 EDT
This incident affected: Acuity Scheduling.