Acuity Scheduling Client Scheduling Pages Not Loading

Incident Report for Acuity Scheduling

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 13:25 EDT

Investigating

We are currently experiencing a service disruption where Acuity Client Scheduling Pages are not loading as expected.

Our Engineering team is working to identify the root cause and implement a solution. All users and services may be affected.

We will provide an update as soon as possible.
Posted Oct 14, 2025 - 13:10 EDT
This incident affected: Acuity Scheduling.