Acuity Scheduling / Acuity doesn't load for some users

Incident Report for Acuity Scheduling

Resolved

The issue appears isolated to a small set of users located in geographic regions affected by network outages.
Posted Sep 24, 2025 - 09:37 EDT

Monitoring

The issue appears isolated to a small set of users located in geographic regions affected by network outages.
Posted Sep 24, 2025 - 09:34 EDT

Update

We are continuing to investigate the issue.
Posted Sep 24, 2025 - 07:37 EDT

Investigating

We are currently investigating the issue.
Posted Sep 24, 2025 - 07:11 EDT
This incident affected: Acuity Scheduling.