Acuity Scheduling Slow Loading
Incident Report for Acuity Scheduling
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 12:16 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2020 - 11:20 EDT
Identified
The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted Oct 21, 2020 - 10:55 EDT
This incident affected: Acuity Scheduling, Change Scheduling Wording/Translation, API and Syncing (Google Syncing, iCloud, Office 365, Outlook.com and Exchange).