Intermittent error message or slow loading on scheduling page

Incident Report for Acuity Scheduling

Resolved

This issue has been resolved.
Posted Jul 07, 2026 - 10:16 EDT

Investigating

We are currently investigating this issue.
Posted Jul 07, 2026 - 10:08 EDT
This incident affected: Acuity Scheduling.