Acuity Scheduling / Google calendar sync delayed

Incident Report for Acuity Scheduling

Resolved

The issue has been resolved.
Posted Aug 20, 2026 - 10:30 EDT

Update

We are continuing to investigate this issue.
Posted Aug 20, 2026 - 08:25 EDT

Investigating

We are currently investigating an issue causing Google calendar syncing to be delayed. This may also delay the creation of Google Meet links for appointments.
Posted Aug 20, 2026 - 08:25 EDT
This incident affected: Acuity Scheduling.