Admins having difficulty scheduling from mobile web view
Incident Report for Acuity Scheduling
Resolved
This incident has been resolved.
Posted Nov 09, 2023 - 07:38 EST
Investigating
We are currently investigating this issue.
Posted Nov 09, 2023 - 06:36 EST
This incident affected: Acuity Scheduling.