Degraded Sync performance for Microsoft 365
Incident Report for Acuity Scheduling
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 17:38 EST
Update
We are continuing to monitor the situation with Microsoft 365.
Posted Nov 25, 2024 - 14:31 EST
Monitoring
Microsoft Outlook Syncing is currently delayed due to the Microsoft incident "MO941162". Microsoft is investigating the issue and working toward a fix but a timeline to resolution has not been provided. We are monitoring the situation and will provide an update as soon as possible.
Posted Nov 25, 2024 - 14:30 EST
This incident affected: Acuity Scheduling.