Issues with appointment booking

Incident Report for Acuity Scheduling

Resolved

The issue was determined to be a problem with our observability tool, rather than an issue affecting Acuity businesses and clients.
Posted Oct 27, 2025 - 08:19 EDT

Monitoring

Some clients may have had issues paying for and confirming appointments around 7am-7:30am US Eastern time. A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 07:37 EDT
This incident affected: Acuity Scheduling.