Issues using PayPal at checkout to pay for Acuity Scheduling subscriptions

Incident Report for Acuity Scheduling

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 17:37 EDT

Update

We are continuing to work on a fix for the issue.
Posted Mar 27, 2025 - 17:00 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 27, 2025 - 14:58 EDT

Investigating

We’re currently experiencing issues with using PayPal at checkout to pay for Acuity Scheduling subscriptions.

Our Engineering team is working to identify the root cause and implement a solution.

We will provide an update as soon as possible.
Posted Mar 27, 2025 - 14:10 EDT
This incident affected: Acuity Scheduling.