We are experiencing a disruption with one of our payment processors, transactions and other integrations may be impacted

Incident Report for Acuity Scheduling

Resolved

This incident has been resolved.
Posted Feb 06, 2024 - 13:11 EST

Investigating

We are currently investigating this issue.
Posted Feb 06, 2024 - 11:20 EST
This incident affected: Acuity Scheduling.