Acuity Scheduling Slow Loading

Incident Report for Acuity Scheduling

Resolved

This incident has been resolved.
Posted Mar 10, 2021 - 17:45 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2021 - 17:17 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 10, 2021 - 16:24 EST

Identified

The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We've identified the cause and will provide an update as soon as possible.
Posted Mar 10, 2021 - 16:23 EST
This incident affected: Acuity Scheduling.