Unable to start new trial

Incident Report for Acuity Scheduling

Resolved

The issue has been resolved.
Posted May 12, 2025 - 12:15 EDT

Monitoring

A fix has been implemented, and the issue has been mitigated. We are monitoring the results.
Posted May 12, 2025 - 11:58 EDT

Investigating

Users are unable to start a new trial from the Acuity frontsite.
Posted May 12, 2025 - 11:15 EDT
This incident affected: Acuity Scheduling.