Clients are unable to redeem coupons at checkout on the Acuity Client Scheduling Page

Incident Report for Acuity Scheduling

Resolved

The issue has been resolved.
Posted Nov 20, 2025 - 13:13 EST

Investigating

We are currently investigating this issue.
Posted Nov 20, 2025 - 13:00 EST
This incident affected: Acuity Scheduling.