Acuity Scheduling - iCloud sync issues

Incident Report for Acuity Scheduling

Identified

The issue has been identified by our iCloud syncing provider and they are working on a fix.
Posted Jun 19, 2026 - 10:01 EDT

Update

We are continuing to investigate this issue.
Posted Jun 17, 2026 - 14:23 EDT

Investigating

We are aware of iCloud calendar sync problems affecting some users, resulting in delayed or missing events. We are currently investigating the issue.
Posted Jun 16, 2026 - 16:39 EDT
This incident affects: Acuity Scheduling.