Acuity Scheduling Slow Loading
Incident Report for Acuity Scheduling
Resolved
This incident has been resolved.
Posted Mar 03, 2020 - 14:45 EST
Investigating
The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted Mar 03, 2020 - 14:20 EST
This incident affected: Acuity Scheduling, API and Syncing (Google Syncing, iCloud, Office 365, Outlook.com and Exchange).