Intermittent errors loading Client Scheduling Page
Incident Report for Acuity Scheduling
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 14:57 EST
Investigating
We are currently investigating this issue.
Posted Feb 27, 2024 - 14:52 EST
This incident affected: Acuity Scheduling.