Acuity Scheduling / Intermittent loading issues

Incident Report for Acuity Scheduling

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 14:23 EDT

Investigating

We are currently investigating issues with Client Scheduling Pages and Acuity Admin pages not loading. We recommend refreshing the page periodically which can help with loading.
Posted Apr 17, 2026 - 14:08 EDT