Acuity Scheduling Slow Loading and Intermittent Errors

Incident Report for Acuity Scheduling

Resolved

This incident has been resolved.
Posted Mar 07, 2025 - 09:24 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2025 - 08:43 EST

Investigating

The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive and intermittent errors. We're investigating the cause and will provide an update as soon as possible.
Posted Mar 07, 2025 - 08:22 EST
This incident affected: Acuity Scheduling.