Acuity Scheduling Slow Loading
Incident Report for Acuity Scheduling
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 14:56 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 15, 2021 - 14:31 EST
Monitoring
The site is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.
Posted Nov 15, 2021 - 14:31 EST
This incident affected: Syncing (Google Syncing, iCloud, Office 365, Outlook.com and Exchange) and Acuity Scheduling, Change Scheduling Wording/Translation, API.