Change Scheduling Wording Interruption
Incident Report for Acuity Scheduling, Inc.
Resolved
Our hosting provider for change scheduling wording is back up and responding normally again
Posted over 1 year ago. Sep 06, 2016 - 16:49 EDT
Investigating
Our change scheduling wording provider is currently experiencing downtime and translations are not being displayed. We'll update as soon as we have more info. Thank you for your patience!
Posted over 1 year ago. Sep 06, 2016 - 14:33 EDT