Acuity Scheduling outage.
Incident Report for Acuity Scheduling, Inc.
Resolved
Our developers are quick wizards. Downtime is resolved.
Posted about 1 month ago. Aug 15, 2018 - 15:33 EDT
Investigating
Our team is currently investing the issue and will be back ASAP!
Posted about 1 month ago. Aug 15, 2018 - 15:31 EDT
This incident affected: Acuity Scheduling.